Zum Inhalt wechseln


Foto

Kein Upload auf FTP


  • Please log in to reply
9 Antworten in diesem Thema

#1 scorpio65

scorpio65

    Neu bei uns

  • Mitglieder
  • PIP
  • 2 Beiträge

Geschrieben 23 Mai 2005 - 14:36

Habe heute per Newsletter vom neuen Programm "Net Synchronizer v1.0" erfahren und es gleich in der Standard Edition (max. 1MB Daten) ausprobiert.
Dazu nutze ich die NAS DiscStation DS-101 von http://www.synology.com.

- Unter "Einstellungen" -> "Optionen" -> Register "Allgemein" bleibt die Einstellung für Report immer auf "Bei aufgetretenen Fehlern immer anzeigen" und kann nicht geändert werden.
- Ein Backup kann problemlos ausgeführt werden
- Auch eine Synchronisation von der DiskStation zum PC arbeitet einwandfrei
- Der umgekehrte Weg, PC zu DiskStation, auch bei aktivierter Funktion "Passiver FTP-Modus", jedoch nicht.

Fehlermeldung dann: "die Datei "C:/xyz" konnte nicht auf den Server nach "\\xyz" geladen werden.

Mit der Freeware "Filezilla" klappt's einwandfrei. Auch kann ich via InternetExplorer (ftp://name.. ) zugreifen. Alle Firewalls (in WinXP und in beiden ADSL-Routern) wurden testweise deaktiviert.

#2 AS_Manuel

AS_Manuel

    Blickt langsam durch

  • Mitglieder
  • PIPPIPPIP
  • 37 Beiträge
  • Location:Stuttgart u. Augsburg
  • Interests:Programmieren, Kaffee trinken, Programmieren.. ;)

Geschrieben 23 Mai 2005 - 16:49

Hallo,

Es ist eine verbesserte Version von Net Synchronizer verfügbar.
Der Fehler bei der Anzeige der Report - Auswahl wurde behoben,
zusätzlich wurde der FTP Upload modifiziert.
Falls der FTP Upload immer noch nicht funktionieren sollte:
Werden nur bestimmte Dateien oder alle nicht übertragen?
Mit freundlichen Grüßen,

Manuel Remedios, ASCOMP Software

#3 scorpio65

scorpio65

    Neu bei uns

  • Mitglieder
  • PIP
  • 2 Beiträge

Geschrieben 24 Mai 2005 - 07:38

Hallo Hr. Remedios

Der Fehler bei der Anzeige der Report - Auswahl scheint behoben zu sein.
Das Problem mit dem Upload (Synchronisieren) klappt immer noch nicht.
Anbei die Protokolldatei (gekürzt/Mehrfacheinträge entfernt) woraus die
versch. Dateitypen ersichtlich sind.

Synchronisation Test Upload gestartet am 24.05.2005 um 08:31 Uhr
Synchronisation - von Lokal nach Remote
Die Datei C:\_A\Netsync\VPN einrichten.doc konnte nicht auf den Server nach /netsynch/VPN einrichten.doc geladen werden
Datei C:\_A\Netsync\VPN einrichten.doc konnte nicht nach "/netsynch/VPN einrichten.doc" hochgeladen werden!
Die Datei C:\_A\Netsync\waidmann.dvg konnte nicht auf den Server nach /netsynch/waidmann.dvg geladen werden
Datei C:\_A\Netsync\waidmann.dvg konnte nicht nach "/netsynch/waidmann.dvg" hochgeladen werden!
Die Datei C:\_A\Netsync\Textdokument.txt konnte nicht auf den Server nach /netsynch/Textdokument.txt geladen werden
Datei C:\_A\Netsync\Textdokument.txt konnte nicht nach "/netsynch/Textdokument.txt" hochgeladen werden!
Die Datei C:\_A\Netsync\GeplanteTask_entf.reg konnte nicht auf den Server nach /netsynch/GeplanteTask_entf.reg geladen werden
Datei C:\_A\Netsync\GeplanteTask_entf.reg konnte nicht nach "/netsynch/GeplanteTask_entf.reg" hochgeladen werden!
Es wurde(n) 0 Datei(en) von 5 transferiert.

#4 AS_Manuel

AS_Manuel

    Blickt langsam durch

  • Mitglieder
  • PIPPIPPIP
  • 37 Beiträge
  • Location:Stuttgart u. Augsburg
  • Interests:Programmieren, Kaffee trinken, Programmieren.. ;)

Geschrieben 25 Mai 2005 - 08:01

Hallo,

da wir hier leider nicht die entsprechende Testumgebung
zur Verfügung haben kann ich den Fehler nicht reproduzieren.
Net Synchronizer ist generell für Standardkonforme FTP
Server ausgelegt, viele kleinere FTP Server arbeiteten
nicht ganz 100%ig wie es die Spezifikation vorsieht.
Mit freundlichen Grüßen,

Manuel Remedios, ASCOMP Software

#5 HansiE

HansiE

    Neu bei uns

  • Mitglieder
  • PIP
  • 3 Beiträge

Geschrieben 08 Oktober 2006 - 19:12

Hallo!

Habe mir gestern NetSync v.1.0.1.0 heruntergeladen und installiert.

Jedoch funktioniert leider kein einziger Backup Vorgang auf meinem Backup (FTP)Server in Verwendung mit NetSync..
Weder noch die Backup noch die Synchronisation funktioniert.
Habe bereits ca. 8 Stunden nach dem Fehler gesucht jedoch keinen gefunden.
Ich verwendete "FileZilla v.0.9.19 beta" und "Quick'n Easy FTP Server 3.1 Lite".

===============================
Backupvorgang
Protokolle in Verwendung mit FileZilla:
==
NetSync:
Backup Eigene Dateie gestartet: 08.10.2006 um 19:55 Uhr
Dateiname: C:\Dokumente und Einstellungen\Hansi\Eigene Dateien\Eigene Dateie[part].zip


Es wurden keine neuen oder vernderten Dateien gefunden
==



==
FileZilla:
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> Connected, sending welcome message...
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> 220-FileZilla Server version 0.9.19 beta
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> 220-written by Tim Kosse (Tim.Kosse@gmx.de)
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> 220 Please visit http://sourceforge.n...ects/filezilla/
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> USER Natcomp
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> 331 Password required for natcomp
(000008) 08.10.2006 19:55:12 - (not logged in) (10.0.0.142)> PASS **********
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> 230 Logged on
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> TYPE I
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> 200 Type set to I
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> SYST
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> 215 UNIX emulated by FileZilla
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> disconnected.
==


===============================
Protokolle in Verwendung mit Quick'n Easy FTP Server:
==
NetSync:
Backup Eigene Dateie gestartet: 08.10.2006 um 20:01 Uhr
Dateiname: C:\Dokumente und Einstellungen\Hansi\Eigene Dateien\Eigene Dateie[part].zip


Es wurden keine neuen oder vernderten Dateien gefunden
==

==
Quick'n Easy FTP Server:
20:01:13.255 [752] Client connected from 10.0.0.142.
20:01:13.285 [752] 220 Welcome to Quick 'n Easy FTP Server
20:01:13.285 [752] USER Natcomp
20:01:13.455 [752] 331 Password required for Natcomp
20:01:13.455 [752] PASS **********
20:01:13.455 [752] 230 User successfully logged in.
20:01:13.455 [752] TYPE I
20:01:13.455 [752] 200 Type set to BINARY
20:01:13.455 [752] SYST
20:01:13.455 [752] 215 UNIX emulated by Quick 'n Easy FTP Server.
20:01:13.475 [752] Client disconnected from 10.0.0.142.
==


Bei den beiden genannten FTP- Servern wurden alle Berechtigungen gesetzt, ich kann auch mit einem beliebigen FTP Client darauf zugreifen und meine Dateien weiterhin von hand sichern.


Das selbe Problem tritt auch Lokal auf und eine Firewall gibt es im Moment nicht.


Mit freundlichen Grüssen
Hansi

#6 t.korth

t.korth

    Lernt fleißig

  • Mitglieder
  • PIPPIP
  • 25 Beiträge
  • Location:Rostock

Geschrieben 11 November 2006 - 09:00

Ein ähnliches Problem habe ich auch.

Es wäre schön, wenn sich jemand von ASCOMP dazu äußern könnte und die Probleme nicht einfach ignoriert!


Grüße

Tino Korth

#7 AStroebel (ASCOMP)

AStroebel (ASCOMP)

    Administrator

  • Admin
  • PIPPIPPIPPIPPIPPIP
  • 5.556 Beiträge
  • Gender:Male

Geschrieben 11 November 2006 - 18:26

Das hier ist ein ANWENDERFORUM! ;)
Viele Gruesse / Best regards

Andreas Stroebel, ASCOMP Software GmbH

#8 udowerner

udowerner

    Weiß alles

  • Mitglieder
  • PIPPIPPIPPIPPIPPIP
  • 756 Beiträge
  • Gender:Male
  • Location:Berlin

Geschrieben 11 November 2006 - 21:24

(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> 215 UNIX emulated by FileZilla
(000008) 08.10.2006 19:55:12 - natcomp (10.0.0.142)> disconnected.
20:01:13.455 [752] 215 UNIX emulated by Quick 'n Easy FTP Server.
20:01:13.475 [752] Client disconnected from 10.0.0.142.
Ich weiß nicht warum - der Client beendet die Verbindung. Normalerweise würde an der Stelle "PORT" oder "PWD" kommen. PORT ist für die Angabe eines unprivilegierten Ports für die Datenverbindung. Da scheint was schief zu gehen und da der Client (NetSynch) hier offensichtlich "die Tür zu" macht, würde ich das Problem da vermuten.
Sobald ich etwas Zeit habe, werde ich mal versuchen dieses Problem nachzustellen, indem ich verschiedene Einstellungen an der Umgebung ändere und auch einen der von Dir verwendeten FTP-Server testen.
Was ich interessant finde ist die Feststellung, daß es mit "den üblichen" FTP-Servern im Internet klappt. Es könnte also auch eine Problematik bei den Unix-Windows-Unterschieden liegen.

die Datei "C:/xyz" konnte nicht auf den Server nach "\\xyz" geladen werden.

Da sehe ich gleich zwei Probleme - das erste ist kein gültiger Windows-Pfad, das zweite kein gültiger Unix-Pfad und unter Windows ein Remote-Pfad.
-Udo

Origin: Gelassen läuft's!

#9 HansiE

HansiE

    Neu bei uns

  • Mitglieder
  • PIP
  • 3 Beiträge

Geschrieben 12 November 2006 - 23:11

Kann es sein das von NetSync keine Sonderzeichen und keine langen (sehr langen) Dateinamen unterstützt werden?
Oder liegt dieses Problem eher am FTP Server?

Habe wieder einen Backupvorgang erstellt mit dem ich lehre Textdateien auf den FTP Server kopieren wollte, die Textdateien wahren mit 1.txt bis 5.txt benannt.
Hab nur nicht ganz kapiert wieso bei diesem Backupvorgang die Files vom FTP Server auf die lokale Platte kopiert wurden und nicht umgekehrt...
(Server ist auch Local vorhanden).

Bei einem Synchronisations Vorgang trat wieder ein Fehler auf, habe dann die Dateien händisch ins FTP Freigabe-Verzeichnis kopiert und nun klappte auch schon der Backupvorgang mit NetSync.
Nur gibt das keinen wesentlichen Sinn, man kann somit ja nur Dateien vom PC auf den FTP Server Synchronisieren die auch schon am Zielverzeichnis (FTP Server) vorhanden sind.


LG Hansi

#10 udowerner

udowerner

    Weiß alles

  • Mitglieder
  • PIPPIPPIPPIPPIPPIP
  • 756 Beiträge
  • Gender:Male
  • Location:Berlin

Geschrieben 17 November 2006 - 10:22

Ich habe das aktuelle Verhalten von NetSynchronizer bei einer Lokal->Server-Synchronisation mal getestet:
- Verzeichnis lokal enthält Dateien
- Verzeichnis remote ist leer
- Start des Jobs: Für jede Datei lokal wird ein LIST auf dem Server ausgeführt
- Jedes List verläuft (erwartungsgemäß) nicht erfolgreich - die Dateien gibt es dort schließlich noch nicht.
- Für jedes nicht erfolgreiche List kommt (wenn man nicht den stillen Modus fährt) eine "Bestätigung", ob der Auftrag auf Grund dieses "gescheiterten" Listings abgebrochen werden soll
Frage: Warum sollte der Auftrag an der Stelle abgebrochen werden? Es ist doch gerade der Sinn, Dateien die noch nicht vorhanden sind auf diese Weise auch auf den Server zu transferieren - oder nicht? Und warum werden sie im Anschluß nicht kopiert?

Außerdem dauert der Vorgang sehr lange. Ich würde vorschlagen, in einer späteren Version immer komplette Verzeichnisse zu listen und die Datei- und Verzeichnisteile als Liste vergleichen - das dürfte den Vorgang um ein Vielfaches beschleunigen.
-Udo

Origin: Gelassen läuft's!




Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0