Zum Inhalt wechseln


Foto

Bug bei: "Festplatte bereinigen: Temp-Verzeichnis (System)"


  • Please log in to reply
4 Antworten in diesem Thema

#1 thor.a

thor.a

    Neu bei uns

  • Mitglieder
  • PIP
  • 6 Beiträge

Geschrieben 30 Juli 2014 - 17:01

Der Befehl 

 

"Festplatte bereinigen: Temp-Verzeichnis (System) "

 

löscht den Inhalt des Ordners C:\Windows\Temp. Dieses ist falsch, da das temporäre Verzeichnis über die Umgebungsvariablen TMP und TEMP (System) festgelegt wird und somit auf völlig andere Verzeichnisse zeigen kann.

 

Beim Bereinigen des Temp-Verzeichnises (User) werden hingegen die Umgebungsvariablen TMP und TEMP (user) korrekt ausgewertet.

 

Danke für eine Korrektur!

 

Thorsten



#2 thor.a

thor.a

    Neu bei uns

  • Mitglieder
  • PIP
  • 6 Beiträge

Geschrieben 23 November 2015 - 17:39

Ist dieser Fehler jetzt in der Version 4.3 korrigiert? 



#3 AStroebel (ASCOMP)

AStroebel (ASCOMP)

    Administrator

  • Admin
  • PIPPIPPIPPIPPIPPIP
  • 5.557 Beiträge
  • Gender:Male

Geschrieben 23 November 2015 - 18:48

Hallo,

 

was du meinst ist der temporäre Ordner der Benutzers, dieser ist über die Umgebungsvariable %temp% definiert bzw. ermittelbar (Option "Temp-Verzeichnis (Benutzer)").

 

Secure Eraser bietet außerdem die Möglichkeit, den Temp-Ordner im Windows-Ordner zu leeren, diese Funktion ist davon unabhängig und ermittelt lediglich den Windows-Ordner sowie den zugehörigen Temp-Ordner.

 

Eine Korrektur war daher nicht notwendig, eine Änderung wurde also nicht implementiert.


Viele Gruesse / Best regards

Andreas Stroebel, ASCOMP Software GmbH

#4 thor.a

thor.a

    Neu bei uns

  • Mitglieder
  • PIP
  • 6 Beiträge

Geschrieben 23 November 2015 - 20:02

Hallo Andreas,

 

ich meine nicht die temporären Ordner des Benutzers, sondern die Systems. Sorry, ich habe es vielleicht nicht ganz so ausführlich beschrieben, daher nochmal (siehe Screenshot):

 

Ich habe die Systemvariablen TEMP und TMP auf ein anderes (gleiches) Verzeichnis gelegt (C:\tmp-sys\win7-system). Dieses Verzeichnis wird durch Secure Eraser nicht berücksichtigt. Es löscht weiterhin C:\windows\temp, welches auf meinem System gar nicht mehr benutzt wird.

 

Zusätzlich zu den Systemvariablen TEMP und TMP habe ich auch die Benutzervariablen TEMP und TMP entsprechend umgebogen. Diese Änderung klappt mit Secure Eraser.

 

Thorsten

 

 

Angehängte Dateien



#5 AStroebel (ASCOMP)

AStroebel (ASCOMP)

    Administrator

  • Admin
  • PIPPIPPIPPIPPIPPIP
  • 5.557 Beiträge
  • Gender:Male

Geschrieben 23 November 2015 - 23:35

Hallo Thorsten,

 

okay, verstehe jetzt das Problem.

 

Wir werden das im nächsten Update berücksichtigen, danke für deinen Hinweis!


Viele Gruesse / Best regards

Andreas Stroebel, ASCOMP Software GmbH




Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0